FreeBSD : pango -- remote DoS vulnerability (5a757a31-f98e-4bd4-8a85-f1c0f3409769)

High Nessus Plugin ID 117864

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

libpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via crafted text with invalid Unicode sequences.

Solution

Update the affected package.

See Also

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15120

http://www.nessus.org/u?025947ad

http://www.nessus.org/u?f3893d70

http://www.nessus.org/u?31b3c4fc

Plugin Details

Severity: High

ID: 117864

File Name: freebsd_pkg_5a757a31f98e4bd48a85f1c0f3409769.nasl

Version: 1.1

Type: local

Published: 2018/10/02

Modified: 2018/10/02

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:pango, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/10/01

Vulnerability Publication Date: 2018/08/06

Reference Information

CVE: CVE-2018-15120

EDB-ID: 45263