FreeBSD : Gitlab -- multiple vulnerabilities (065b3b72-c5ab-11e8-9ae2-001b217b3468)

High Nessus Plugin ID 117863

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

Gitlab reports :

SSRF GCP access token disclosure

Persistent XSS on issue details

Diff formatter DoS in Sidekiq jobs

Confidential information disclosure in events API endpoint

validate_localhost function in url_blocker.rb could be bypassed

Slack integration CSRF Oauth2

GRPC::Unknown logging token disclosure

IDOR merge request approvals

Persistent XSS package.json

Persistent XSS merge request project import

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?f5636338

http://www.nessus.org/u?505d6daf

Plugin Details

Severity: High

ID: 117863

File Name: freebsd_pkg_065b3b72c5ab11e89ae2001b217b3468.nasl

Version: 1.1

Type: local

Published: 2018/10/02

Modified: 2018/10/02

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:gitlab-ce, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/10/01

Vulnerability Publication Date: 2018/10/01

Reference Information

CVE: CVE-2018-15472, CVE-2018-17449, CVE-2018-17450, CVE-2018-17451, CVE-2018-17452, CVE-2018-17453, CVE-2018-17454, CVE-2018-17455, CVE-2018-17536, CVE-2018-17537