openSUSE Security Update : dom4j (openSUSE-2018-1077)

Medium Nessus Plugin ID 117852

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for dom4j fixes the following issues :

- CVE-2018-1000632: Prevent XML injection vulnerability that allowed an attacker to tamper with XML documents (bsc#1105443)

This update was imported from the SUSE:SLE-12:Update update project.

Solution

Update the affected dom4j packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1105443

Plugin Details

Severity: Medium

ID: 117852

File Name: openSUSE-2018-1077.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/10/01

Modified: 2018/10/01

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:dom4j, p-cpe:/a:novell:opensuse:dom4j-demo, p-cpe:/a:novell:opensuse:dom4j-javadoc, p-cpe:/a:novell:opensuse:dom4j-manual, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2018/09/28

Reference Information

CVE: CVE-2018-1000632