EulerOS 2.0 SP3 : exiv2 (EulerOS-SA-2018-1287)

Medium Nessus Plugin ID 117731

Synopsis

The remote EulerOS host is missing multiple security updates.

Description

According to the versions of the exiv2 package installed, the EulerOS
installation on the remote host is affected by the following
vulnerabilities :

- Exiv2 0.26 has an integer overflow in the
LoaderExifJpeg class in preview.cpp, leading to an
out-of-bounds read in Exiv2::MemIo::read in
basicio.cpp.(CVE-2018-12265)

- Exiv2 0.26 has integer overflows in
LoaderTiff::getData() in preview.cpp, leading to an
out-of-bounds read in Exiv2::ValueType::setDataArea in
value.hpp.(CVE-2018-12264)

Note that Tenable Network Security has extracted the preceding
description block directly from the EulerOS security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

Solution

Update the affected exiv2 packages.

See Also

http://www.nessus.org/u?908e3d13

Plugin Details

Severity: Medium

ID: 117731

File Name: EulerOS_SA-2018-1287.nasl

Version: 1.2

Type: local

Published: 2018/09/27

Modified: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:exiv2-libs, cpe:/o:huawei:euleros:2.0

Patch Publication Date: 2018/09/06

Reference Information

CVE: CVE-2018-12264, CVE-2018-12265