Amazon Linux 2 : postgresql (ALAS-2018-1080)

Medium Nessus Plugin ID 117709

Synopsis

The remote Amazon Linux 2 host is missing a security update.

Description

A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to properly reset its internal state between connections. If an affected version of libpq were used with 'host' or 'hostaddr' connection parameters from untrusted input, attackers could bypass client-side connection security features, obtain access to higher privileged connections or potentially cause other impact through SQL injection, by causing the PQescape() functions to malfunction.(CVE-2018-10915)

Solution

Run 'yum update postgresql' to update your system.

See Also

https://alas.aws.amazon.com/AL2/ALAS-2018-1080.html

Plugin Details

Severity: Medium

ID: 117709

File Name: al2_ALAS-2018-1080.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/09/27

Modified: 2018/10/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:postgresql, p-cpe:/a:amazon:linux:postgresql-contrib, p-cpe:/a:amazon:linux:postgresql-debuginfo, p-cpe:/a:amazon:linux:postgresql-devel, p-cpe:/a:amazon:linux:postgresql-docs, p-cpe:/a:amazon:linux:postgresql-libs, p-cpe:/a:amazon:linux:postgresql-plperl, p-cpe:/a:amazon:linux:postgresql-plpython, p-cpe:/a:amazon:linux:postgresql-pltcl, p-cpe:/a:amazon:linux:postgresql-server, p-cpe:/a:amazon:linux:postgresql-static, p-cpe:/a:amazon:linux:postgresql-test, p-cpe:/a:amazon:linux:postgresql-upgrade, cpe:/o:amazon:linux:2

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2018/09/25

Reference Information

CVE: CVE-2018-10915

ALAS: 2018-1080