openSUSE Security Update : openslp (openSUSE-2018-1040)

High Nessus Plugin ID 117688

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for openslp fixes the following issues :

- CVE-2017-17833: Prevent heap-related memory corruption issue which may have manifested itself as a denial-of-service or a remote code-execution vulnerability (bsc#1090638)

- Prevent out of bounds reads in message parsing This update was imported from the SUSE:SLE-12:Update update project.

Solution

Update the affected openslp packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1090638

Plugin Details

Severity: High

ID: 117688

File Name: openSUSE-2018-1040.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/09/25

Updated: 2018/09/25

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:openslp, p-cpe:/a:novell:opensuse:openslp-32bit, p-cpe:/a:novell:opensuse:openslp-debuginfo, p-cpe:/a:novell:opensuse:openslp-debuginfo-32bit, p-cpe:/a:novell:opensuse:openslp-debugsource, p-cpe:/a:novell:opensuse:openslp-devel, p-cpe:/a:novell:opensuse:openslp-server, p-cpe:/a:novell:opensuse:openslp-server-debuginfo, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2018/09/24

Reference Information

CVE: CVE-2017-17833