Debian DSA-4301-1 : mediawiki - security update

Medium Nessus Plugin ID 117645

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple security vulnerabilities have been discovered in MediaWiki, a website engine for collaborative work, which result in incorrectly configured rate limits, information disclosure in Special:Redirect/logid and bypass of an account lock.

Solution

Upgrade the mediawiki packages.

For the stable distribution (stretch), these problems have been fixed in version 1:1.27.5-1~deb9u1.

See Also

https://security-tracker.debian.org/tracker/source-package/mediawiki

https://packages.debian.org/source/stretch/mediawiki

https://www.debian.org/security/2018/dsa-4301

Plugin Details

Severity: Medium

ID: 117645

File Name: debian_DSA-4301.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2018/09/24

Updated: 2018/11/26

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:mediawiki, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/09/22

Reference Information

CVE: CVE-2018-0503, CVE-2018-0504, CVE-2018-0505

DSA: 4301