Apache ActiveMQ 5.x < 5.14.0 ActiveMQ Fileserver web application remote code execution (Xbash)

critical Nessus Plugin ID 117601
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is running a web application that is affected by a remote code execution vulnerability.

Description

The version of Apache ActiveMQ running on the remote host is 5.x prior to 5.14.0. It is, therefore, affected by a remote code execution vulnerability. The Fileserver web application allows remote attackers to upload and execute arbitrary files.

Solution

Upgrade to Apache ActiveMQ version 5.14.0 or later.

See Also

http://www.nessus.org/u?2581a08b

Plugin Details

Severity: Critical

ID: 117601

File Name: activemq_5_14_0.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 9/19/2018

Updated: 4/5/2019

Dependencies: activemq_web_console_detect.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2016-3088

VPR

Risk Factor: Critical

Score: 9.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:activemq

Required KB Items: installed_sw/ActiveMQ, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 8/8/2016

Vulnerability Publication Date: 6/1/2016

Exploitable With

Metasploit (ActiveMQ web shell upload)

Reference Information

CVE: CVE-2016-3088

BID: 90827