CVE-2016-3088

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote attackers to upload and execute arbitrary files via an HTTP PUT followed by an HTTP MOVE request.

References

http://activemq.apache.org/security-advisories.data/CVE-2016-3088-announcement.txt

http://rhn.redhat.com/errata/RHSA-2016-2036.html

http://www.securitytracker.com/id/1035951

http://www.zerodayinitiative.com/advisories/ZDI-16-356

http://www.zerodayinitiative.com/advisories/ZDI-16-357

https://lists.apache.org/thread.html/[email protected]%3Ccommits.activemq.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Cusers.activemq.apache.org%3E

https://www.exploit-db.com/exploits/42283/

Details

Source: MITRE

Published: 2016-06-01

Updated: 2019-03-27

Type: CWE-20

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* versions up to 5.13.3 (inclusive)

Tenable Plugins

View all (1 total)

IDNameProductFamilySeverity
117601Apache ActiveMQ 5.x < 5.14.0 ActiveMQ Fileserver web application remote code execution (Xbash)NessusCGI abuses
critical