PHP 7.1.x < 7.1.22 Transfer-Encoding Parameter XSS Vulnerability

Medium Nessus Plugin ID 117499

Synopsis

The version of PHP running on the remote web server is affected by a cross-site scripting vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is 7.1.x prior to 7.1.22. It is, therefore, affected by a cross-site scripting vulnerability. An attacker could leverage this vulnerability to inject malicious code which executes within the security context of the affected site.

Solution

Upgrade to PHP version 7.1.22 or later.

See Also

http://php.net/ChangeLog-7.php#7.1.22

https://bugs.php.net/bug.php?id=76582

Plugin Details

Severity: Medium

ID: 117499

File Name: php_7_1_22.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2018/09/14

Modified: 2018/09/20

Dependencies: 48243, 48204

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Score typical of an xss vulnerability

CVSSv2

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSSv3

Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/Apache

Patch Publication Date: 2018/09/13

Vulnerability Publication Date: 2018/09/13

Reference Information

CVE: CVE-2018-17082

IAVB: 2018-B-0126