PHP 5.6.x < 5.6.38 Transfer-Encoding Parameter XSS Vulnerability

medium Nessus Plugin ID 117497

Synopsis

The version of PHP running on the remote web server is affected by a cross-site scripting Vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is 5.6.x prior to 5.6.38. It is, therefore, affected by a cross-site scripting vulnerability. An attacker could leverage this vulnerability to inject malicious code which executes within the security context of the affected site.

Solution

Upgrade to PHP version 5.6.38 or later.

See Also

http://php.net/ChangeLog-5.php#5.6.38

https://bugs.php.net/bug.php?id=76582

Plugin Details

Severity: Medium

ID: 117497

File Name: php_5_6_38.nasl

Version: 1.8

Type: remote

Family: CGI abuses

Published: 9/14/2018

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 4.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2018-17082

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/Apache

Exploit Ease: No known exploits are available

Patch Publication Date: 9/13/2018

Vulnerability Publication Date: 9/13/2018

Reference Information

CVE: CVE-2018-17082