PHP 5.6.x < 5.6.38 Transfer-Encoding Parameter XSS Vulnerability

medium Nessus Plugin ID 117497
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The version of PHP running on the remote web server is affected by a cross-site scripting Vulnerability.


According to its banner, the version of PHP running on the remote web server is 5.6.x prior to 5.6.38. It is, therefore, affected by a cross-site scripting vulnerability. An attacker could leverage this vulnerability to inject malicious code which executes within the security context of the affected site.


Upgrade to PHP version 5.6.38 or later.

See Also

Plugin Details

Severity: Medium

ID: 117497

File Name: php_5_6_38.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 9/14/2018

Updated: 11/1/2019

Dependencies: php_version.nasl, apache_http_version.nasl

Risk Information

CVSS Score Source: CVE-2018-17082


Risk Factor: Low

Score: 3


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/Apache

Exploit Ease: No known exploits are available

Patch Publication Date: 9/13/2018

Vulnerability Publication Date: 9/13/2018

Reference Information

CVE: CVE-2018-17082