Artifex Ghostscript Multiple Vulnerabilities

High Nessus Plugin ID 117459

Synopsis

The remote Windows host contains a library that is affected by multiple vulnerabilities.

Description

The version of Artifex Ghostscript installed on the remote Windows host is prior to 9.24. It is, therefore, affected by multiple vulnerabilities due to improperly handling PostScript data. A context-dependent attacker could cause a buffer overflow, potentially crashing the service.

Solution

Update to 9.24.

See Also

https://ghostscript.com/doc/9.24/History9.htm

https://www.debian.org/security/2018/dsa-4288

https://www.artifex.com/news/ghostscript-security-resolved/

https://bugs.chromium.org/p/project-zero/issues/detail?id=1640

https://bugs.ghostscript.com/show_bug.cgi?id=699654

Plugin Details

Severity: High

ID: 117459

File Name: ghostscript_9_24.nasl

Version: 1.2

Type: local

Agent: windows

Family: Windows

Published: 2018/09/12

Modified: 2018/09/17

Dependencies: 100357

Risk Information

Risk Factor: High

CVSS Score Source: manual

CVSS Score Rationale: Score based on analysis of the vendor advisory.

CVSSv2

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSSv3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:artifex:ghostscript, cpe:/a:artifex:gpl_ghostscript

Required KB Items: installed_sw/Ghostscript

Patch Publication Date: 2018/09/03

Vulnerability Publication Date: 2018/09/03

Reference Information

CVE: CVE-2018-15908, CVE-2018-15909, CVE-2018-15910, CVE-2018-15911, CVE-2018-16511, CVE-2018-16513, CVE-2018-16539, CVE-2018-16540, CVE-2018-16541, CVE-2018-16542, CVE-2018-16543, CVE-2018-16585