Apache Struts 2.x < 2.3.16.2 Multiple ClassLoader Manipulation Vulnerabilities (S2-021)

High Nessus Plugin ID 117457

Synopsis

A web application running on the remote host uses a Java framework that is affected by multiple ClassLoader manipulation vulnerabilities.

Description

The version of Apache Struts running on the remote host is 2.x prior to 2.3.16.2. It, therefore, is affected by multiple ClassLoader vulnerabilities.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.3.16.2 or later

See Also

https://cwiki.apache.org/confluence/display/WW/S2-021

Plugin Details

Severity: High

ID: 117457

File Name: struts_2_3_16_2.nasl

Version: 1.3

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/12

Modified: 2018/09/17

Dependencies: 99671, 11936, 73943

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2014-0112

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/04/24

Vulnerability Publication Date: 2014/04/24

Exploitable With

Metasploit (Apache Struts ClassLoader Manipulation Remote Code Execution)

Elliot (Apache-Struts DefaultActionMapper < 2.3.15.1 RCE Linux)

Reference Information

CVE: CVE-2014-0112, CVE-2014-0113

BID: 61189, 61196