FreeBSD : Plex Media Server -- Information Disclosure Vulnerability (337960ec-b5dc-11e8-ac58-a4badb2f4699)

High Nessus Plugin ID 117441

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

Chris reports :

The XML parsing engine for Plex Media Server's SSDP/UPNP functionality is vulnerable to an XML External Entity Processing (XXE) attack.
Unauthenticated attackers on the same LAN can use this vulnerability to :

- Access arbitrary files from the filesystem with the same permission as the user account running Plex.

- Initiate SMB connections to capture NetNTLM challenge/response and crack to clear-text password.

- Initiate SMB connections to relay NetNTLM challenge/response and achieve Remote Command Execution in Windows domains.

Solution

Update the affected packages.

See Also

https://seclists.org/fulldisclosure/2018/Aug/1

http://www.nessus.org/u?3af4673a

Plugin Details

Severity: High

ID: 117441

File Name: freebsd_pkg_337960ecb5dc11e8ac58a4badb2f4699.nasl

Version: 1.1

Type: local

Published: 2018/09/12

Modified: 2018/09/12

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:plexmediaserver, p-cpe:/a:freebsd:freebsd:plexmediaserver-plexpass, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/09/11

Vulnerability Publication Date: 2018/08/01

Reference Information

CVE: CVE-2018-13415