Apache Struts 2.x < 2.3.14.3 RCE (S2-015)

High Nessus Plugin ID 117389

Synopsis

A web application running on the remote host uses a Java framework that is affected by a remote command execution vulnerability.

Description

The version of Apache Struts running on the remote host is 2.x prior to 2.3.14.3. It, therefore, is affected by a remote command execution vulnerability.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.3.14.3 or later

See Also

https://cwiki.apache.org/confluence/display/WW/S2-015

Plugin Details

Severity: High

ID: 117389

File Name: struts_2_3_14_3.nasl

Version: 1.3

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/09/10

Modified: 2018/09/17

Dependencies: 11936, 99671, 73943

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2013-2134

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/06/03

Vulnerability Publication Date: 2013/06/03

Reference Information

CVE: CVE-2013-2134, CVE-2013-2135

BID: 60345, 60346