CVE-2013-2134

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted action name that is not properly handled during wildcard matching, a different vulnerability than CVE-2013-2135.

References

http://security.gentoo.org/glsa/glsa-201409-04.xml

http://struts.apache.org/development/2.x/docs/s2-015.html

http://www.oracle.com/technetwork/topics/security/cpujan2014-1972949.html

http://www.oracle.com/technetwork/topics/security/cpuoct2013-1899837.html

http://www.securityfocus.com/bid/60346

http://www.securityfocus.com/bid/64758

https://cwiki.apache.org/confluence/display/WW/S2-015

Details

Source: MITRE

Published: 2013-07-16

Updated: 2018-11-23

Type: CWE-94

Risk Information

CVSS v2

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:*

Tenable Plugins

View all (3 total)

IDNameProductFamilySeverity
117389Apache Struts 2.x < 2.3.14.3 RCE (S2-015)NessusMisc.
critical
77548GLSA-201409-04 : MySQL: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
66931Apache Struts 2 OGNL Expression Handling Double Evaluation Error Remote Command ExecutionNessusCGI abuses
high