Debian DSA-4288-1 : ghostscript - security update

High Nessus Plugin ID 117369

Synopsis

The remote Debian host is missing a security-related update.

Description

Tavis Ormandy discovered multiple vulnerabilites in Ghostscript, an interpreter for the PostScript language, which could result in denial of service, the creation of files or the execution of arbitrary code if a malformed Postscript file is processed (despite the dSAFER sandbox being enabled).

Solution

Upgrade the ghostscript packages.

For the stable distribution (stretch), these problems have been fixed in version 9.20~dfsg-3.2+deb9u4.

See Also

https://security-tracker.debian.org/tracker/ghostscript

https://packages.debian.org/source/stretch/ghostscript

http://www.debian.org/security/2018/dsa-4288

Plugin Details

Severity: High

ID: 117369

File Name: debian_DSA-4288.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/09/10

Modified: 2018/09/10

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ghostscript, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/09/07

Reference Information

CVE: CVE-2018-15908, CVE-2018-15910, CVE-2018-15911, CVE-2018-16511, CVE-2018-16513, CVE-2018-16539, CVE-2018-16540, CVE-2018-16541, CVE-2018-16542, CVE-2018-16543, CVE-2018-16585

DSA: 4288