Debian DLA-1496-1 : lcms2 security update

Medium Nessus Plugin ID 117350

Synopsis

The remote Debian host is missing a security update.

Description

It was discovered that there was an integer overflow vulnerability in the 'Little CMS 2' colour management library. A specially crafted input file could lead to a heap-based buffer overflow.

For Debian 8 'Jessie', this issue has been fixed in lcms2 version 2.6-3+deb8u2.

We recommend that you upgrade your lcms2 packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/09/msg00005.html

https://packages.debian.org/source/jessie/lcms2

Plugin Details

Severity: Medium

ID: 117350

File Name: debian_DLA-1496.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/09/07

Modified: 2018/11/06

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:liblcms2-2, p-cpe:/a:debian:debian_linux:liblcms2-dbg, p-cpe:/a:debian:debian_linux:liblcms2-dev, p-cpe:/a:debian:debian_linux:liblcms2-utils, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/09/06

Reference Information

CVE: CVE-2018-16435