CVE-2018-16435

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Little CMS (aka Little Color Management System) 2.9 has an integer overflow in the AllocateDataSet function in cmscgats.c, leading to a heap-based buffer overflow in the SetData function via a crafted file in the second argument to cmsIT8LoadFromFile.

References

https://github.com/mm2/Little-CMS/issues/171

https://github.com/mm2/Little-CMS/commit/768f70ca405cd3159d990e962d54456773bb8cf8

https://www.debian.org/security/2018/dsa-4284

https://lists.debian.org/debian-lts-announce/2018/09/msg00005.html

https://usn.ubuntu.com/3770-2/

https://usn.ubuntu.com/3770-1/

https://access.redhat.com/errata/RHSA-2018:3004

https://security.gentoo.org/glsa/202105-18

Details

Source: MITRE

Published: 2018-09-04

Updated: 2021-05-26

Type: CWE-787

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM

Tenable Plugins

View all (24 total)

IDNameProductFamilySeverity
151329EulerOS Virtualization for ARM 64 3.0.2.0 : lcms2 (EulerOS-SA-2021-2098)NessusHuawei Local Security Checks
medium
147528EulerOS Virtualization 3.0.6.6 : lcms2 (EulerOS-SA-2021-1488)NessusHuawei Local Security Checks
medium
146707EulerOS 2.0 SP2 : lcms2 (EulerOS-SA-2021-1313)NessusHuawei Local Security Checks
medium
145163EulerOS 2.0 SP3 : lcms2 (EulerOS-SA-2021-1081)NessusHuawei Local Security Checks
medium
142091EulerOS 2.0 SP5 : lcms2 (EulerOS-SA-2020-2286)NessusHuawei Local Security Checks
medium
131507EulerOS Virtualization for ARM 64 3.0.3.0 : lcms2 (EulerOS-SA-2019-2342)NessusHuawei Local Security Checks
medium
123364openSUSE Security Update : lcms2 (openSUSE-2019-880)NessusSuSE Local Security Checks
medium
121152openSUSE Security Update : java-1_8_0-openjdk (openSUSE-2019-43)NessusSuSE Local Security Checks
critical
121151openSUSE Security Update : java-1_7_0-openjdk (openSUSE-2019-42) (Spectre)NessusSuSE Local Security Checks
medium
121092SUSE SLED15 / SLES15 Security Update : java-1_8_0-openjdk (SUSE-SU-2019:0058-1)NessusSuSE Local Security Checks
critical
121091SUSE SLED12 / SLES12 Security Update : java-1_8_0-openjdk (SUSE-SU-2019:0057-1)NessusSuSE Local Security Checks
critical
121059SUSE SLED12 / SLES12 Security Update : java-1_7_0-openjdk (SUSE-SU-2019:0049-1) (Spectre)NessusSuSE Local Security Checks
medium
120933Fedora 28 : chromium (2018-fd194a1f14)NessusFedora Local Security Checks
high
120500Fedora 29 : lcms2 (2018-6ac39c63c4)NessusFedora Local Security Checks
medium
120342Fedora 29 : chromium (2018-34f7f68029)NessusFedora Local Security Checks
high
120272Fedora 28 : lcms2 (2018-1cb4c4a6d8)NessusFedora Local Security Checks
medium
120148SUSE SLED15 / SLES15 Security Update : lcms2 (SUSE-SU-2018:3498-1)NessusSuSE Local Security Checks
medium
118500SUSE SLED12 / SLES12 Security Update : lcms2 (SUSE-SU-2018:3545-1)NessusSuSE Local Security Checks
high
118489openSUSE Security Update : lcms2 (openSUSE-2018-1327)NessusSuSE Local Security Checks
medium
118373RHEL 6 : chromium-browser (RHSA-2018:3004)NessusRed Hat Local Security Checks
critical
117927Fedora 27 : lcms2 (2018-3e9f26489b)NessusFedora Local Security Checks
medium
117631Ubuntu 14.04 LTS / 16.04 LTS / 18.04 LTS : Little CMS vulnerabilities (USN-3770-1)NessusUbuntu Local Security Checks
high
117350Debian DLA-1496-1 : lcms2 security updateNessusDebian Local Security Checks
medium
112280Debian DSA-4284-1 : lcms2 - security updateNessusDebian Local Security Checks
medium