phpMyAdmin < 4.8.3 Vulnerability (PMASA-2018-5)

Medium Nessus Plugin ID 117334

Synopsis

The remote web server hosts a PHP application that is affected by a cross-site Scripting vulnerability.

Description

According to its self-reported version number, the phpMyAdmin application hosted on the remote web server is prior to 4.8.3. It is, therefore, affected by a cross-site Scripting vulnerability.

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to phpMyAdmin version 4.8.3 or later.
Alternatively, apply the patch referenced in the vendor advisory.

See Also

https://www.phpmyadmin.net/security/PMASA-2018-5/

Plugin Details

Severity: Medium

ID: 117334

File Name: phpmyadmin_pmasa_2018_5.nasl

Version: 1.2

Type: remote

Published: 2018/09/06

Modified: 2018/09/17

Dependencies: 17219

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Score based on analysis of the vendor advisory.

CVSSv2

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSSv3

Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Required KB Items: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

Patch Publication Date: 2018/08/21

Vulnerability Publication Date: 2018/08/21

Reference Information

CVE: CVE-2018-15605

BID: 105168