Kerio Personal Firewall Administrator Authentication Handshake Packet Remote Buffer Overflow

High Nessus Plugin ID 11575


The remote service is affected by a buffer overflow vulnerability.


Kerio Personal Firewall is vulnerable to a buffer overflow attack involving the administrator authentication process. An attacker may use this to crash Kerio or to execute arbitrary code on the system.


Unknown at this time.

See Also

Plugin Details

Severity: High

ID: 11575

File Name: kerio_PF_buffer_overflow.nasl

Version: $Revision: 1.18 $

Type: remote

Family: Firewalls

Published: 2003/05/06

Modified: 2016/10/27

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:kerio:personal_firewall

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2003/04/28

Exploitable With

Core Impact

Metasploit (Kerio Firewall 2.1.4 Authentication Packet Overflow)

Reference Information

CVE: CVE-2003-0220

BID: 7180

OSVDB: 6294