MySQL < 3.23.55 mysql_change_user() Double-free Memory Pointer DoS

medium Nessus Plugin ID 11299
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database service is prone to a denial of service attack.

Description

According to its banner, a version of MySQL before 3.23.55 is running on the remote host. If you have not patched this version, then an attacker with valid credentials may be able to crash this service remotely by exploiting a double free bug.

Further exploitation to gain a shell on the host might be possible, although it's unconfirmed so far.

Solution

Upgrade to MySQL 3.23.55 or newer.

Plugin Details

Severity: Medium

ID: 11299

File Name: mysql_double_free.nasl

Version: 1.30

Type: remote

Family: Databases

Published: 3/1/2003

Updated: 7/16/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mysql:mysql:*:*:*:*:*:*:*:*

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 1/23/2003

Reference Information

CVE: CVE-2003-0073

BID: 6718