Debian DSA-4284-1 : lcms2 - security update

High Nessus Plugin ID 112280

Synopsis

The remote Debian host is missing a security-related update.

Description

Quang Nguyen discovered an integer overflow in the Little CMS 2 colour management library, which could result in denial of service and potentially the execution of arbitrary code if a malformed IT8 calibration file is processed.

Solution

Upgrade the lcms2 packages.

For the stable distribution (stretch), this problem has been fixed in version 2.8-4+deb9u1.

See Also

https://security-tracker.debian.org/tracker/lcms2

https://packages.debian.org/source/stretch/lcms2

http://www.debian.org/security/2018/dsa-4284

Plugin Details

Severity: High

ID: 112280

File Name: debian_DSA-4284.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/09/05

Modified: 2018/09/05

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:lcms2, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/09/04

Reference Information

CVE: CVE-2018-16435

DSA: 4284