FreeBSD : Gitlab -- multiple vulnerabilities (ffeb25d0-ac94-11e8-ab15-d8cb8abf62dd)

High Nessus Plugin ID 112198

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

Gitlab reports :

Persistent XSS in Pipeline Tooltip

GitLab.com GCP Endpoints Exposure

Persistent XSS in Merge Request Changes View

Sensitive Data Disclosure in Sidekiq Logs

Missing CSRF in System Hooks

Orphaned Upload Files Exposure

Missing Authorization Control API Repository Storage

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?20eacea3

http://www.nessus.org/u?9a8a43f1

Plugin Details

Severity: High

ID: 112198

File Name: freebsd_pkg_ffeb25d0ac9411e8ab15d8cb8abf62dd.nasl

Version: 1.2

Type: local

Published: 2018/08/31

Modified: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:gitlab-ce, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/08/30

Vulnerability Publication Date: 2018/08/28