Apache ActiveMQ 5.x < 5.15.5 Multiple Vulnerabilities

critical Nessus Plugin ID 112192


A web application running on the remote host is affected by multiple vulnerabilities.


The version of Apache ActiveMQ running on the remote host is 5.x prior to 5.15.5. It is, therefore, affected by multiple vulnerabilities.


Upgrade to Apache ActiveMQ version 5.15.5 or later.

See Also


Plugin Details

Severity: Critical

ID: 112192

File Name: activemq_5_15_5.nasl

Version: 1.10

Type: combined

Agent: unix

Family: CGI abuses

Published: 8/30/2018

Updated: 4/19/2024

Configuration: Enable thorough checks

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information


Risk Factor: Critical

Score: 9.5


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2018-7489


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:activemq

Required KB Items: installed_sw/Apache ActiveMQ

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 8/6/2018

Vulnerability Publication Date: 8/6/2018

CISA Known Exploited Vulnerability Due Dates: 6/2/2023

Exploitable With

Metasploit (Apache Struts ClassLoader Manipulation Remote Code Execution)

Reference Information

CVE: CVE-2012-0881, CVE-2014-0114, CVE-2015-5182, CVE-2016-3092, CVE-2016-5425, CVE-2016-6325, CVE-2016-8735, CVE-2018-7489, CVE-2018-8006

BID: 67121, 68753, 91453, 93472, 93478, 94463, 103203, 105156