Apache ActiveMQ 5.x < 5.15.5 Multiple Vulnerabilities

High Nessus Plugin ID 112192

Synopsis

A web application running on the remote host is affected by multiple vulnerabilities.

Description

The version of Apache ActiveMQ running on the remote host is 5.x prior to 5.15.5. It is, therefore, affected by multiple vulnerabilities.

Solution

Upgrade to Apache ActiveMQ version 5.15.5 or later.

See Also

http://activemq.apache.org/activemq-5155-release.html

Plugin Details

Severity: High

ID: 112192

File Name: activemq_5_15_5.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2018/08/30

Modified: 2018/09/17

Dependencies: 45552

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2016-3092

CVSSv2

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:apache:activemq

Required KB Items: installed_sw/ActiveMQ

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/08/06

Vulnerability Publication Date: 2018/08/06

Exploitable With

Metasploit (Apache Struts ClassLoader Manipulation Remote Code Execution)

Reference Information

CVE: CVE-2012-0881, CVE-2014-0114, CVE-2015-5182, CVE-2016-3092, CVE-2016-5425, CVE-2016-6325, CVE-2016-8735, CVE-2018-7489, CVE-2018-8006

BID: 68753, 105156, 67121, 91453, 93472, 93478, 94463, 103203