Debian DSA-4269-1 : postgresql-9.6 - security update

Medium Nessus Plugin ID 111653

Synopsis

The remote Debian host is missing a security-related update.

Description

Two vulnerabilities have been found in the PostgreSQL database system :

- CVE-2018-10915 Andrew Krasichkov discovered that libpq did not reset all its connection state during reconnects.

- CVE-2018-10925 It was discovered that some 'CREATE TABLE' statements could disclose server memory.

For additional information please refer to the upstream announcement at https://www.postgresql.org/about/news/1878/

Solution

Upgrade the postgresql-9.6 packages.

For the stable distribution (stretch), these problems have been fixed in version 9.6.10-0+deb9u1.

See Also

https://security-tracker.debian.org/tracker/CVE-2018-10915

https://security-tracker.debian.org/tracker/CVE-2018-10925

https://www.postgresql.org/about/news/1878/

http://www.nessus.org/u?350b32e8

https://packages.debian.org/source/stretch/postgresql-9.6

https://www.debian.org/security/2018/dsa-4269

Plugin Details

Severity: Medium

ID: 111653

File Name: debian_DSA-4269.nasl

Version: 1.5

Type: local

Agent: unix

Published: 2018/08/13

Updated: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:postgresql-9.6, cpe:/o:debian:debian_linux:9.0

Patch Publication Date: 2018/08/10

Reference Information

CVE: CVE-2018-10915, CVE-2018-10925

DSA: 4269