openSUSE Security Update : libsoup (openSUSE-2018-856)

High Nessus Plugin ID 111637

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for libsoup fixes the following issues :

Security issue fixed :

- CVE-2018-12910: Fix crash when handling empty hostnames (bsc#1100097).

- CVE-2017-2885: Fix chunk decoding buffer overrun that could be exploited against either clients or servers (bsc#1052916).

Bug fixes :

- bsc#1086036: translation-update-upstream commented out for Leap

This update was imported from the SUSE:SLE-12-SP2:Update update project.

Solution

Update the affected libsoup packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1052916

https://bugzilla.opensuse.org/show_bug.cgi?id=1086036

https://bugzilla.opensuse.org/show_bug.cgi?id=1100097

Plugin Details

Severity: High

ID: 111637

File Name: openSUSE-2018-856.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/08/10

Modified: 2018/09/04

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSSv3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libsoup-2_4-1, p-cpe:/a:novell:opensuse:libsoup-2_4-1-32bit, p-cpe:/a:novell:opensuse:libsoup-2_4-1-debuginfo, p-cpe:/a:novell:opensuse:libsoup-2_4-1-debuginfo-32bit, p-cpe:/a:novell:opensuse:libsoup-debugsource, p-cpe:/a:novell:opensuse:libsoup-devel, p-cpe:/a:novell:opensuse:libsoup-devel-32bit, p-cpe:/a:novell:opensuse:libsoup-lang, p-cpe:/a:novell:opensuse:typelib-1_0-Soup-2_4, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2018/08/09

Reference Information

CVE: CVE-2017-2885, CVE-2018-12910