openSUSE Security Update : java-11-openjdk (openSUSE-2018-830)

Medium Nessus Plugin ID 111597

Synopsis

The remote openSUSE host is missing a security update.

Description

This java-11-openjdk update to version jdk-11+24 fixes the following issues :

Security issues fixed :

- CVE-2018-2940: Fix unspecified vulnerability in subcomponent Libraries (bsc#1101645).

- CVE-2018-2952: Fix unspecified vulnerability in subcomponent Concurrency (bsc#1101651).

- CVE-2018-2972: Fix unspecified vulnerability in subcomponent Security (bsc#1101655).

- CVE-2018-2973: Fix unspecified vulnerability in subcomponent JSSE (bsc#1101656).

This update was imported from the SUSE:SLE-15:Update update project.

Solution

Update the affected java-11-openjdk packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1101645

https://bugzilla.opensuse.org/show_bug.cgi?id=1101651

https://bugzilla.opensuse.org/show_bug.cgi?id=1101655

https://bugzilla.opensuse.org/show_bug.cgi?id=1101656

Plugin Details

Severity: Medium

ID: 111597

File Name: openSUSE-2018-830.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/08/09

Modified: 2018/08/09

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:java-11-openjdk, p-cpe:/a:novell:opensuse:java-11-openjdk-accessibility, p-cpe:/a:novell:opensuse:java-11-openjdk-accessibility-debuginfo, p-cpe:/a:novell:opensuse:java-11-openjdk-debuginfo, p-cpe:/a:novell:opensuse:java-11-openjdk-debugsource, p-cpe:/a:novell:opensuse:java-11-openjdk-demo, p-cpe:/a:novell:opensuse:java-11-openjdk-devel, p-cpe:/a:novell:opensuse:java-11-openjdk-headless, p-cpe:/a:novell:opensuse:java-11-openjdk-javadoc, p-cpe:/a:novell:opensuse:java-11-openjdk-jmods, p-cpe:/a:novell:opensuse:java-11-openjdk-src, cpe:/o:novell:opensuse:15.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2018/08/08

Reference Information

CVE: CVE-2018-2940, CVE-2018-2952, CVE-2018-2972, CVE-2018-2973