FreeBSD : rubygem-doorkeeper -- token revocation vulnerability (e309a2c7-598b-4fa6-a398-bc72fbd1d167)

High Nessus Plugin ID 111480

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

NVD reports :

Doorkeeper version 4.2.0 and later contains a Incorrect Access Control vulnerability in Token revocation API's authorized method that can result in Access tokens are not revoked for public OAuth apps, leaking access until expiry.

Solution

Update the affected packages.

See Also

https://nvd.nist.gov/vuln/detail/CVE-2018-1000211

https://github.com/doorkeeper-gem/doorkeeper/pull/1120

http://www.nessus.org/u?46e6d7e9

Plugin Details

Severity: High

ID: 111480

File Name: freebsd_pkg_e309a2c7598b4fa6a398bc72fbd1d167.nasl

Version: 1.2

Type: local

Published: 2018/08/02

Modified: 2018/08/06

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:rubygem-doorkeeper, p-cpe:/a:freebsd:freebsd:rubygem-doorkeeper-rails5, p-cpe:/a:freebsd:freebsd:rubygem-doorkeeper-rails50, p-cpe:/a:freebsd:freebsd:rubygem-doorkeeper43, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/07/31

Vulnerability Publication Date: 2018/07/13

Reference Information

CVE: CVE-2018-1000211