openSUSE Security Update : qutebrowser (openSUSE-2018-775)

Medium Nessus Plugin ID 111427

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for qutebrowser fixes the following issues :

Security issue fixed :

- CVE-2018-1000559: Fix an XSS issue on qute://history (boo#1101507).

- CVE-2018-10895: Fix CSRF issue on the qute://settings page (boo#1100968).

Solution

Update the affected qutebrowser package.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1100968

https://bugzilla.opensuse.org/show_bug.cgi?id=1101507

Plugin Details

Severity: Medium

ID: 111427

File Name: openSUSE-2018-775.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/07/30

Modified: 2018/07/30

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:qutebrowser, cpe:/o:novell:opensuse:15.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2018/07/28

Reference Information

CVE: CVE-2018-1000559, CVE-2018-10895