openSUSE Security Update : e2fsprogs (openSUSE-2018-771)

Medium Nessus Plugin ID 111423

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for e2fsprogs fixes the following issues :

Security issues fixed :

- CVE-2015-0247: Fixed couple of heap overflows in e2fsprogs (fsck, dumpe2fs, e2image...) (bsc#915402).

- CVE-2015-1572: Fixed potential buffer overflow in closefs() (bsc#918346).

Bug fixes :

- bsc#1038194: generic/405 test fails with /dev/mapper/thin-vol is inconsistent on ext4 file system.

- bsc#1009532: resize2fs hangs when trying to resize a large ext4 file system.

- bsc#960273: xfsprogs does not call %{?regenerate_initrd_post}.

This update was imported from the SUSE:SLE-15:Update update project.

Solution

Update the affected e2fsprogs packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1009532

https://bugzilla.opensuse.org/show_bug.cgi?id=1038194

https://bugzilla.opensuse.org/show_bug.cgi?id=915402

https://bugzilla.opensuse.org/show_bug.cgi?id=918346

https://bugzilla.opensuse.org/show_bug.cgi?id=960273

Plugin Details

Severity: Medium

ID: 111423

File Name: openSUSE-2018-771.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/07/30

Modified: 2018/07/30

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:e2fsprogs, p-cpe:/a:novell:opensuse:e2fsprogs-32bit-debuginfo, p-cpe:/a:novell:opensuse:e2fsprogs-debuginfo, p-cpe:/a:novell:opensuse:e2fsprogs-debugsource, p-cpe:/a:novell:opensuse:e2fsprogs-devel, p-cpe:/a:novell:opensuse:libcom_err-devel, p-cpe:/a:novell:opensuse:libcom_err-devel-32bit, p-cpe:/a:novell:opensuse:libcom_err-devel-static, p-cpe:/a:novell:opensuse:libcom_err2, p-cpe:/a:novell:opensuse:libcom_err2-32bit, p-cpe:/a:novell:opensuse:libcom_err2-32bit-debuginfo, p-cpe:/a:novell:opensuse:libcom_err2-debuginfo, p-cpe:/a:novell:opensuse:libext2fs-devel, p-cpe:/a:novell:opensuse:libext2fs-devel-32bit, p-cpe:/a:novell:opensuse:libext2fs-devel-static, p-cpe:/a:novell:opensuse:libext2fs2, p-cpe:/a:novell:opensuse:libext2fs2-32bit, p-cpe:/a:novell:opensuse:libext2fs2-32bit-debuginfo, p-cpe:/a:novell:opensuse:libext2fs2-debuginfo, cpe:/o:novell:opensuse:15.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2018/07/28

Reference Information

CVE: CVE-2015-0247, CVE-2015-1572