FreeBSD : lshell -- Multiple security issues (f353525a-d8b8-11e6-a071-001e67f15f5a)

High Nessus Plugin ID 111410

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

lshell reports :

It is possible to escape lshell if an allowed command can execute an arbitrary non allowed one (issue #122).

Inappropriate parsing of commands can lead to arbitrary command execution (issue #147, #149, #151).

Solution

Update the affected package.

See Also

https://github.com/ghantoos/lshell/issues/122

https://github.com/ghantoos/lshell/issues/147

https://github.com/ghantoos/lshell/issues/149

https://github.com/ghantoos/lshell/issues/151

http://www.nessus.org/u?f044387c

Plugin Details

Severity: High

ID: 111410

File Name: freebsd_pkg_f353525ad8b811e6a071001e67f15f5a.nasl

Version: 1.1

Type: local

Published: 2018/07/30

Modified: 2018/07/30

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:lshell, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/07/27

Vulnerability Publication Date: 2016/02/04