FreeBSD : GIMP - Heap Buffer Overflow Vulnerability (bfda2d80-0858-11e8-ad5c-0021ccb9e74d)

Medium Nessus Plugin ID 111408

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

GNOME reports :

CVE-2017-17786 Out of bounds read / heap overflow in tga importer / function bgr2rgb.part.1

Solution

Update the affected package.

See Also

https://bugzilla.gnome.org/show_bug.cgi?id=739134

http://www.nessus.org/u?b769a159

Plugin Details

Severity: Medium

ID: 111408

File Name: freebsd_pkg_bfda2d80085811e8ad5c0021ccb9e74d.nasl

Version: 1.2

Type: local

Published: 2018/07/30

Modified: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:gimp, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/07/27

Vulnerability Publication Date: 2017/12/21

Reference Information

CVE: CVE-2017-17786