FreeBSD : Gitlab -- multiple vulnerabilities (2da838f9-9168-11e8-8c75-d8cb8abf62dd)

High Nessus Plugin ID 111362

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

Gitlab reports :

Markdown DoS

Information Disclosure Prometheus Metrics

CSRF in System Hooks

Persistent XSS Pipeline Tooltip

Persistent XSS in Branch Name via Web IDE

Persistent XSS in Branch Name via Web IDE

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?bef889ef

http://www.nessus.org/u?7ef344ac

Plugin Details

Severity: High

ID: 111362

File Name: freebsd_pkg_2da838f9916811e88c75d8cb8abf62dd.nasl

Version: 1.1

Type: local

Published: 2018/07/27

Modified: 2018/07/27

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:gitlab-ce, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/07/27

Vulnerability Publication Date: 2018/07/26

Reference Information

CVE: CVE-2018-14601, CVE-2018-14602, CVE-2018-14603, CVE-2018-14604, CVE-2018-14605, CVE-2018-14606