SUSE SLED12 / SLES12 Security Update : rsyslog (SUSE-SU-2018:2038-1)

Low Nessus Plugin ID 111262

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for rsyslog fixes the following issues: The following security vulnerability was addressed :

- CVE-2015-3243: Make sure that log files are not created world-readable (bsc#935393)

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Server 12-SP3:zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-1375=1

SUSE Linux Enterprise Desktop 12-SP3:zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-1375=1

SUSE CaaS Platform ALL :

To install this update, use the SUSE CaaS Platform Velum dashboard. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.

See Also

https://bugzilla.suse.com/935393

https://www.suse.com/security/cve/CVE-2015-3243.html

http://www.nessus.org/u?e3f3d02d

Plugin Details

Severity: Low

ID: 111262

File Name: suse_SU-2018-2038-1.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2018/07/24

Modified: 2018/09/05

Dependencies: 12634

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 2.1

Temporal Score: 2.1

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:U/RC:ND

CVSSv3

Base Score: 5.5

Temporal Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:X/RL:U/RC:X

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:rsyslog, p-cpe:/a:novell:suse_linux:rsyslog-debuginfo, p-cpe:/a:novell:suse_linux:rsyslog-debugsource, p-cpe:/a:novell:suse_linux:rsyslog-diag-tools, p-cpe:/a:novell:suse_linux:rsyslog-diag-tools-debuginfo, p-cpe:/a:novell:suse_linux:rsyslog-doc, p-cpe:/a:novell:suse_linux:rsyslog-module-gssapi, p-cpe:/a:novell:suse_linux:rsyslog-module-gssapi-debuginfo, p-cpe:/a:novell:suse_linux:rsyslog-module-gtls, p-cpe:/a:novell:suse_linux:rsyslog-module-gtls-debuginfo, p-cpe:/a:novell:suse_linux:rsyslog-module-mysql, p-cpe:/a:novell:suse_linux:rsyslog-module-mysql-debuginfo, p-cpe:/a:novell:suse_linux:rsyslog-module-pgsql, p-cpe:/a:novell:suse_linux:rsyslog-module-pgsql-debuginfo, p-cpe:/a:novell:suse_linux:rsyslog-module-relp, p-cpe:/a:novell:suse_linux:rsyslog-module-relp-debuginfo, p-cpe:/a:novell:suse_linux:rsyslog-module-snmp, p-cpe:/a:novell:suse_linux:rsyslog-module-snmp-debuginfo, p-cpe:/a:novell:suse_linux:rsyslog-module-udpspoof, p-cpe:/a:novell:suse_linux:rsyslog-module-udpspoof-debuginfo, cpe:/o:novell:suse_linux:12

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/07/23

Reference Information

CVE: CVE-2015-3243

BID: 75298