PHP 7.1.x < 7.1.20 exif_thumbnail_extract() DoS

high Nessus Plugin ID 111231

Synopsis

The version of PHP running on the remote web server is affected by a denial of service vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is 7.1.x prior to 7.1.20. It is, therefore, affected by a denial of service vulnerability.

Solution

Upgrade to PHP version 7.1.20 or later.

See Also

http://www.php.net/ChangeLog-7.php#7.1.20

https://bugs.php.net/bug.php?id=76423

Plugin Details

Severity: High

ID: 111231

File Name: php_7_1_20.nasl

Version: 1.8

Type: remote

Family: CGI abuses

Published: 7/24/2018

Updated: 4/11/2022

Risk Information

CVSS Score Source: CVE-2018-15132

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 7/19/2018

Vulnerability Publication Date: 6/7/2018

Reference Information

CVE: CVE-2018-14851, CVE-2018-14883, CVE-2018-15132