CVE-2018-14883

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

An issue was discovered in PHP before 5.6.37, 7.0.x before 7.0.31, 7.1.x before 7.1.20, and 7.2.x before 7.2.8. An Integer Overflow leads to a heap-based buffer over-read in exif_thumbnail_extract of exif.c.

References

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/104871

https://bugs.php.net/bug.php?id=76423

https://lists.debian.org/debian-lts-announce/2018/09/msg00000.html

https://security.netapp.com/advisory/ntap-20181107-0003/

https://usn.ubuntu.com/3766-1/

https://usn.ubuntu.com/3766-2/

https://www.debian.org/security/2018/dsa-4353

https://www.tenable.com/security/tns-2018-12

Details

Source: MITRE

Published: 2018-08-03

Updated: 2020-08-24

Type: CWE-190

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (14 total)

IDNameProductFamilySeverity
98875PHP 7.1.x < 7.1.20 exif_thumbnail_extract() DoSWeb Application ScanningComponent Vulnerability
high
98874PHP 5.6.x < 5.6.37 exif_thumbnail_extract() DoSWeb Application ScanningComponent Vulnerability
high
119561Debian DSA-4353-1 : php7.0 - security updateNessusDebian Local Security Checks
high
117672Tenable SecurityCenter < 5.7.1 Multiple Vulnerabilities (TNS-2018-12)NessusMisc.
critical
117539Ubuntu 14.04 LTS / 16.04 LTS / 18.04 LTS : PHP vulnerabilities (USN-3766-1)NessusUbuntu Local Security Checks
high
117449SUSE SLES11 Security Update : php53 (SUSE-SU-2018:2681-1)NessusSuSE Local Security Checks
high
117340PHP < 5.6.37 or 7.2.x < 7.2.8 Multiple Vulnerabilities (Deprecated)NessusCGI abuses
high
112229Debian DLA-1490-1 : php5 security updateNessusDebian Local Security Checks
high
112094Amazon Linux AMI : php72 (ALAS-2018-1067)NessusAmazon Linux Local Security Checks
critical
112093Amazon Linux AMI : php56 / php70,php71 (ALAS-2018-1066)NessusAmazon Linux Local Security Checks
high
111231PHP 7.1.x < 7.1.20 exif_thumbnail_extract() DoSNessusCGI abuses
high
111230PHP 5.6.x < 5.6.37 exif_thumbnail_extract() DoSNessusCGI abuses
high
111216PHP 7.2.x < 7.2.8 Use After Free Arbitrary Code Execution in EXIFNessusCGI abuses
critical
111215PHP 7.0.x < 7.0.31 Use After Free Arbitrary Code Execution in EXIFNessusCGI abuses
critical