PHP 5.6.x < 5.6.37 exif_thumbnail_extract() DoS

Medium Nessus Plugin ID 111230

Synopsis

The version of PHP running on the remote web server is affected by a denial of service vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is 5.6.x prior to 5.6.37. It is, therefore, affected by a denial of service vulnerability.

Solution

Upgrade to PHP version 5.6.37 or later.

See Also

http://php.net/ChangeLog-5.php#5.6.37

https://bugs.php.net/bug.php?id=76423

Plugin Details

Severity: Medium

ID: 111230

File Name: php_5_6_37.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2018/07/24

Modified: 2018/07/27

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Cve not assigned. assigning a typical dos score.

CVSSv2

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSSv3

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Patch Publication Date: 2018/07/19

Vulnerability Publication Date: 2018/06/07

Reference Information

IAVB: 2018-B-0091