PHP 7.2.x < 7.2.8 Use After Free Arbitrary Code Execution in EXIF

High Nessus Plugin ID 111216

Synopsis

The version of PHP running on the remote web server is affected by a Use-After-Free Arbitrary Code Execution Vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is 7.2.x prior to 7.2.8. It is, therefore, affected by a Use-After-Free Arbitrary Code Execution Vulnerability.

Solution

Upgrade to PHP version 7.2.8 or later.

See Also

http://php.net/ChangeLog-7.php#7.2.8

Plugin Details

Severity: High

ID: 111216

File Name: php_7_2_8.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 2018/07/20

Updated: 2019/02/26

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-12882

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2018/07/19

Vulnerability Publication Date: 2018/06/03

Reference Information

CVE: CVE-2018-12882, CVE-2018-14851, CVE-2018-14883, CVE-2018-15132

BID: 104551