PHP 7.0.x < 7.0.31 Use After Free Arbitrary Code Execution in EXIF

critical Nessus Plugin ID 111215
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version of PHP running on the remote web server is affected by a Use-After-Free Arbitrary Code Execution Vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is 7.0.x prior to 7.0.31. It is, therefore, affected by a Use-After-Free Arbitrary Code Execution Vulnerability.

Solution

Upgrade to PHP version 7.0.31 or later.

See Also

http://php.net/ChangeLog-7.php#7.0.31

Plugin Details

Severity: Critical

ID: 111215

File Name: php_7_0_31.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 7/20/2018

Updated: 11/4/2019

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2018-12882

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 7/19/2018

Vulnerability Publication Date: 6/3/2018

Reference Information

CVE: CVE-2018-12882, CVE-2018-14851, CVE-2018-14883, CVE-2018-15132

BID: 104551