SUSE SLED12 / SLES12 Security Update : shadow (SUSE-SU-2018:1997-1)

Medium Nessus Plugin ID 111203

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for shadow fixes the following issues :

- CVE-2016-6252: Incorrect integer handling could results in local privilege escalation (bsc#1099310)

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product :

SUSE OpenStack Cloud 7:zypper in -t patch SUSE-OpenStack-Cloud-7-2018-1351=1

SUSE Linux Enterprise Server for SAP 12-SP2:zypper in -t patch SUSE-SLE-SAP-12-SP2-2018-1351=1

SUSE Linux Enterprise Server 12-SP3:zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-1351=1

SUSE Linux Enterprise Server 12-SP2-LTSS:zypper in -t patch SUSE-SLE-SERVER-12-SP2-2018-1351=1

SUSE Linux Enterprise Desktop 12-SP3:zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-1351=1

SUSE Enterprise Storage 4:zypper in -t patch SUSE-Storage-4-2018-1351=1

SUSE CaaS Platform ALL :

To install this update, use the SUSE CaaS Platform Velum dashboard. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.

OpenStack Cloud Magnum Orchestration 7:zypper in -t patch SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-1351=1

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1099310

https://www.suse.com/security/cve/CVE-2016-6252/

http://www.nessus.org/u?79c5ae5e

Plugin Details

Severity: Medium

ID: 111203

File Name: suse_SU-2018-1997-1.nasl

Version: 1.5

Type: local

Agent: unix

Published: 2018/07/20

Modified: 2018/12/01

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.6

Temporal Score: 3.5

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:ND/RC:UC

CVSS v3.0

Base Score: 7.8

Temporal Score: 6.6

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:X/RC:U

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:shadow, p-cpe:/a:novell:suse_linux:shadow-debuginfo, p-cpe:/a:novell:suse_linux:shadow-debugsource, cpe:/o:novell:suse_linux:12

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2018/07/19

Reference Information

CVE: CVE-2016-6252