MySQL 5.5.x < 5.5.61 Multiple Vulnerabilities (July 2018 CPU)

High Nessus Plugin ID 111153

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL running on the remote host is 5.5.x prior to 5.5.61. It is, therefore, affected by multiple vulnerabilities as noted in the July 2018 Critical Patch Update advisory. Please consult the CVRF details for the applicable CVEs for additional information.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MySQL version 5.5.61 or later.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-61.html

http://www.nessus.org/u?50f36723

Plugin Details

Severity: High

ID: 111153

File Name: mysql_5_5_61.nasl

Version: 1.9

Type: remote

Family: Databases

Published: 2018/07/20

Updated: 2019/11/04

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: manual

CVSS Score Rationale: Composite vector of multiple vulnerabilities in the given version

CVSS v2.0

Base Score: 8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.6

Temporal Score: 6.6

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/07/17

Vulnerability Publication Date: 2018/07/17

Reference Information

CVE: CVE-2018-2767, CVE-2018-3058, CVE-2018-3063, CVE-2018-3066, CVE-2018-3070, CVE-2018-3081

BID: 103954, 104766, 104779, 104786