RHEL 6 : flash-plugin (RHSA-2018:2175)

High Nessus Plugin ID 111032

Synopsis

The remote Red Hat host is missing a security update.

Description

An update for flash-plugin is now available for Red Hat Enterprise Linux 6 Supplementary.

Red Hat Product Security has rated this update as having a security impact of Critical. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

The flash-plugin package contains a Mozilla Firefox compatible Adobe Flash Player web browser plug-in.

This update upgrades Flash Player to version 30.0.0.134.

Security Fix(es) :

* flash-plugin: Arbitrary Code Execution vulnerability (APSB18-24) (CVE-2018-5007)

* flash-plugin: Information Disclosure vulnerability (APSB18-24) (CVE-2018-5008)

For more details about the security issue(s), including the impact, a CVSS score, and other related information, refer to the CVE page(s) listed in the References section.

Solution

Update the affected flash-plugin package.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb18-24.html

http://rhn.redhat.com/errata/RHSA-2018-2175.html

https://www.redhat.com/security/data/cve/CVE-2018-5007.html

https://www.redhat.com/security/data/cve/CVE-2018-5008.html

Plugin Details

Severity: High

ID: 111032

File Name: redhat-RHSA-2018-2175.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/07/12

Modified: 2018/07/12

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:flash-plugin, cpe:/o:redhat:enterprise_linux:6

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2018/07/11

Reference Information

CVE: CVE-2018-5007, CVE-2018-5008

RHSA: 2018:2175