Debian DSA-4238-1 : exiv2 - security update

High Nessus Plugin ID 110910

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been discovered in Exiv2, a C++ library and a command line utility to manage image metadata which could result in denial of service or the execution of arbitrary code if a malformed file is parsed.

Solution

Upgrade the exiv2 packages.

For the stable distribution (stretch), these problems have been fixed in version 0.25-3.1+deb9u1.

See Also

https://security-tracker.debian.org/tracker/exiv2

https://packages.debian.org/source/stretch/exiv2

http://www.debian.org/security/2018/dsa-4238

Plugin Details

Severity: High

ID: 110910

File Name: debian_DSA-4238.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/07/05

Modified: 2018/07/05

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:exiv2, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/07/03

Reference Information

CVE: CVE-2018-10958, CVE-2018-10998, CVE-2018-10999, CVE-2018-11531, CVE-2018-12264, CVE-2018-12265

DSA: 4238