EulerOS 2.0 SP3 : libevent (EulerOS-SA-2018-1164)

High Nessus Plugin ID 110740

Synopsis

The remote EulerOS host is missing a security update.

Description

According to the version of the libevent package installed, the EulerOS installation on the remote host is affected by the following vulnerability :

- Multiple integer overflows in the evbuffer API in Libevent 1.4.x before 1.4.15, 2.0.x before 2.0.22, and 2.1.x before 2.1.5-beta allow context-dependent attackers to cause a denial of service or possibly have other unspecified impact via 'insanely large inputs' to the (1) evbuffer_add, (2) evbuffer_expand, or (3) bufferevent_write function, which triggers a heap-based buffer overflow or an infinite loop.(CVE-2014-6272)

Note that Tenable Network Security has extracted the preceding description block directly from the EulerOS security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected libevent package.

See Also

http://www.nessus.org/u?92f35e6a

Plugin Details

Severity: High

ID: 110740

File Name: EulerOS_SA-2018-1164.nasl

Version: 1.3

Type: local

Published: 2018/06/28

Modified: 2018/08/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:libevent, cpe:/o:huawei:euleros:2.0

Required KB Items: Host/local_checks_enabled, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/sp

Excluded KB Items: Host/EulerOS/uvp_version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/06/10

Reference Information

CVE: CVE-2014-6272

BID: 71971