CVE-2014-6272

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Multiple integer overflows in the evbuffer API in Libevent 1.4.x before 1.4.15, 2.0.x before 2.0.22, and 2.1.x before 2.1.5-beta allow context-dependent attackers to cause a denial of service or possibly have other unspecified impact via "insanely large inputs" to the (1) evbuffer_add, (2) evbuffer_expand, or (3) bufferevent_write function, which triggers a heap-based buffer overflow or an infinite loop. NOTE: this identifier has been SPLIT per ADT3 due to different affected versions. See CVE-2015-6525 for the functions that are only affected in 2.0 and later.

References

http://archives.seul.org/libevent/users/Jan-2015/msg00010.html

http://www.debian.org/security/2015/dsa-3119

http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.366317

https://puppet.com/security/cve/CVE-2014-6272

Details

Source: MITRE

Published: 2015-08-24

Updated: 2017-12-09

Type: CWE-189

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*

Configuration 2

OR

cpe:2.3:a:libevent_project:libevent:1.4.0:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:1.4.1:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:1.4.2:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:1.4.3:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:1.4.4:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:1.4.5:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:1.4.6:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:1.4.7:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:1.4.8:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:1.4.9:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:1.4.10:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:1.4.11:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:1.4.12:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:1.4.13:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:1.4.14:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.1:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.2:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.3:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.4:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.5:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.6:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.7:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.8:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.9:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.10:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.11:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.12:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.13:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.14:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.15:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.16:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.17:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.18:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.19:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.20:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.0.21:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.1.1:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.1.2:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.1.3:*:*:*:*:*:*:*

cpe:2.3:a:libevent_project:libevent:2.1.4:*:*:*:*:*:*:*

Tenable Plugins

View all (13 total)

IDNameProductFamilySeverity
131668EulerOS 2.0 SP2 : libevent (EulerOS-SA-2019-2515)NessusHuawei Local Security Checks
high
131027Amazon Linux 2 : libevent (ALAS-2019-1359)NessusAmazon Linux Local Security Checks
high
124942EulerOS Virtualization 3.0.1.0 : libevent (EulerOS-SA-2019-1439)NessusHuawei Local Security Checks
critical
110740EulerOS 2.0 SP3 : libevent (EulerOS-SA-2018-1164)NessusHuawei Local Security Checks
high
90203Slackware 14.1 / current : libevent (SSA:2016-085-01)NessusSlackware Local Security Checks
high
82120Debian DLA-137-1 : libevent security updateNessusDebian Local Security Checks
high
81230GLSA-201502-07 : libevent: User-assisted execution of arbitrary codeNessusGentoo Local Security Checks
high
80992openSUSE Security Update : libevent (openSUSE-SU-2015:0132-1)NessusSuSE Local Security Checks
high
80852Ubuntu 10.04 LTS / 12.04 LTS / 14.04 LTS / 14.10 : libevent vulnerability (USN-2477-1)NessusUbuntu Local Security Checks
high
80454FreeBSD : libevent -- integer overflow in evbuffers (daa8a49b-99b9-11e4-8f66-3085a9a4510d)NessusFreeBSD Local Security Checks
high
80436Mandriva Linux Security Advisory : libevent (MDVSA-2015:017-1)NessusMandriva Local Security Checks
high
80393Debian DSA-3119-1 : libevent - security updateNessusDebian Local Security Checks
high
78253SuSE 11.3 Security Update : libevent (SAT Patch Number 9824)NessusSuSE Local Security Checks
high