openSUSE Security Update : phpMyAdmin (openSUSE-2018-669)

High Nessus Plugin ID 110680

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for phpMyAdmin fixes multiple issues.

Security issues fixed :

- CVE-2018-12613: File inclusion and remote code execution attack (boo#1098751)

- CVE-2018-12581: XSS in Designer feature (boo#1098752)

This update to version 4.8.2 also contains number of upstream bug fixes and improvements.

Solution

Update the affected phpMyAdmin package.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1098751

https://bugzilla.opensuse.org/show_bug.cgi?id=1098752

Plugin Details

Severity: High

ID: 110680

File Name: openSUSE-2018-669.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/06/25

Modified: 2018/07/12

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:phpMyAdmin, cpe:/o:novell:opensuse:15.0, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/06/23

Exploitable With

Metasploit (phpMyAdmin Authenticated Remote Code Execution)

Reference Information

CVE: CVE-2018-12581, CVE-2018-12613