openSUSE Security Update : redis (openSUSE-2018-667)

High Nessus Plugin ID 110678

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for redis to 4.0.10 fixes the following issues :

These security issues were fixed :

- CVE-2018-11218: Prevent heap corruption vulnerability in cmsgpack (bsc#1097430).

- CVE-2018-11219: Prevent integer overflow in Lua scripting (bsc#1097768).

For Leap 42.3 and openSUSE SLE 12 backports this is a jump from 4.0.6.
For additional details please see

- https://raw.githubusercontent.com/antirez/redis/4.0.9/00-RELEASENOTES

- https://raw.githubusercontent.com/antirez/redis/4.0.8/00-RELEASENOTES

- https://raw.githubusercontent.com/antirez/redis/4.0.7/00-RELEASENOTES

Solution

Update the affected redis packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1097430

https://bugzilla.opensuse.org/show_bug.cgi?id=1097768

https://raw.githubusercontent.com/antirez/redis/4.0.7/00-RELEASENOTES

https://raw.githubusercontent.com/antirez/redis/4.0.8/00-RELEASENOTES

https://raw.githubusercontent.com/antirez/redis/4.0.9/00-RELEASENOTES

Plugin Details

Severity: High

ID: 110678

File Name: openSUSE-2018-667.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2018/06/25

Modified: 2018/09/04

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSSv3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:redis, p-cpe:/a:novell:opensuse:redis-debuginfo, p-cpe:/a:novell:opensuse:redis-debugsource, cpe:/o:novell:opensuse:15.0, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2018/06/22

Reference Information

CVE: CVE-2018-11218, CVE-2018-11219