openSUSE Security Update : mupdf (openSUSE-2018-592)

Medium Nessus Plugin ID 110435

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for mupdf fixes the following security issue :

- CVE-2018-1000051: Prevent use after free in fz_keep_key_storable that can result in DOS / possible code execution. This attack appear to be exploitable via Victim opens a specially crafted PDF (bsc#1080531).

Solution

Update the affected mupdf packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1080531

Plugin Details

Severity: Medium

ID: 110435

File Name: openSUSE-2018-592.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/06/11

Modified: 2018/06/11

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSSv3

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:mupdf, p-cpe:/a:novell:opensuse:mupdf-debuginfo, p-cpe:/a:novell:opensuse:mupdf-debugsource, p-cpe:/a:novell:opensuse:mupdf-devel-static, cpe:/o:novell:opensuse:15.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2018/06/09

Reference Information

CVE: CVE-2018-1000051