FreeBSD : gnupg -- unsanitized output (CVE-2018-12020) (7da0417f-6b24-11e8-84cc-002590acae31)

Medium Nessus Plugin ID 110430

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

GnuPG reports :

GnuPG did not sanitize input file names, which may then be output to the terminal. This could allow terminal control sequences or fake status messages to be injected into the output.

Solution

Update the affected packages.

See Also

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12020

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7526

http://www.nessus.org/u?38d2a0a0

Plugin Details

Severity: Medium

ID: 110430

File Name: freebsd_pkg_7da0417f6b2411e884cc002590acae31.nasl

Version: 1.7

Type: local

Published: 2018/06/11

Updated: 2019/05/07

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:gnupg, p-cpe:/a:freebsd:freebsd:gnupg1, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/06/08

Vulnerability Publication Date: 2018/06/07

Reference Information

CVE: CVE-2017-7526, CVE-2018-12020